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Important Information

Sibelius SE6 Template 6.0a, May 2012

This Readme is to be used with this Template file *:
SE6_Template_6.0a.sib

The above Template file is to be used with this sound set:
SE6_SoundSet_6.0a.xml

Abirds eye view of where to access the sounds during note input with a MIDI keyboard or Sibelius’ built-in keyboard
can be found in the file named SE6_Maps_6.0a.pdf. The unpitched percussion mapping diagrams can also be
found in this document.

SE6 Template 6.0a supports the Sibelius Sounds Essentials sample library that is included with Sibelius 6. This
template is NOT backwards compatible with earlier versions of Sibelius; it is compatible with Sibelius 7.

[l

Merge-Compatible: The “a” part of the SE6 Template 6.0a name reflects the update to it that makes it compatible
with the TWS Sibelius 7 family of templates. View the current list here.

When the term “SEB” is used, it will be referring to the Sibelius Sounds Essentials sample library that is included
with Sibelius 6.

When the term “Sibelius” is used by itself, it will be referring to Sibelius 6.
When the term “Template” is used by itself, it will be referring to SE6 Template 6.0a.
When the term “TWS” is used, it will be referring to The Write Score.

As we move along in this document, be aware that not all of the features of Sibelius will be discussed in detail. If
you feel you need to reference something that we do not specifically cover, please be sure to use your Sibelius
Reference Guide to find what you're looking for.

Many of the software navigation paths are followed by “(hover)”, this will give you an image of what it refers to when
you hover your cursor over that text.

This Template is for new projects going forward. If you have scores that originated outside of this template,
please see Appendix A for possible conversion scenarios.

The primary reason for this Readme is to guide you in using the Template. Once you get the hang of it, you
won'’t have much need for this document.

You will need to use Adobe Reader 5 or later to view the interactive elements in the SE6_Maps_6.0a PDF
and this document. Get the latest free version here: get.adobe.com/reader/

All TWS template packages available for download are placed in .zip archives. You will need to unpack their contents
to access the enclosed files. Please read this FAQ if you have troubles doing so.

Please direct your Product Support questions to the TWS Forum. The template developers are setup to handle
those sorts of inquiries there.



Getting Started

Your Writing Environment

There are a few items that you will need to have before you can start using this Template:

1. Sibelius 6
2. Sibelius Sounds Essentials (Sibelius Player version)

Install Sibelius

Once you've installed Sibelius 6, be sure you’re running the latest version. Get the Sibelius 6.2
update here:

www.sibelius.com/helpcenter/upgrades.html

Install Sibelius Sounds Essentials

Make sure you install the Essentials sample library that is on your Sibelius 6 DVD after you
install the program.

Install SE6 SoundSet 6.0a

Find the file labeled SE6_SoundSet_6.0a.xml and copy it into one of the following folders * (this
file is included within the SE6 Template zip package you downloaded):

Windows XP:
Sib 6: C:\Documents and Settings\your username\Application Data\Sibelius Software\Sibelius 6\Sounds
Sib 7: C:\Documents and Settings\your username\Application Data\Avid\Sibelius 7\Sounds

Windows Vista / Windows 7:
Sib 6: C:\Users\your username\AppData\Roaming\Sibelius Software\Sibelius 6\Sounds
Sib 7: C:\Users\your username\AppData\Roaming\Avid\Sibelius 7\Sounds

Mac OS X:
Sib 6: /Users/your username/Library/Application Support/Sibelius Software/Sibelius 6/Sounds
Sib 7: /Users/your username/Library/Application Support/Avid/Sibelius 7/Sounds

* You may have to create the Sounds folder yourself.



Why do | need this particular sound set?

1. A sound set is an XML file that has all of the relevant information allowing Sibelius to
communicate with whatever library/device the sound set is written for. In this case, the
SE6 SoundSet 6.0a sound set will allow Sibelius to correctly sort out all the instruments,
techniques, articulations, controllers, and keyswitches for every instrument in the Template.

2. This sound set has been customized to distinguish itself from any other sound set that a
user may have in use in a particular Playback Configuration. We want specific patches
to be loaded - especially if other sample libraries are in simultaneous use.

NOTE: Make sure that you install and use the sound set that you downloaded with the
Template so all the instruments that we’ve defined will function properly.

Now that you have installed Sibelius, the Sibelius Sounds Essentials library and the included
sound set, let’s set up your Playback Configuration.



Playback Configuration

Once the software has loaded, navigate to Play > Playback Devices (hover). One of the first
things you will need to do before you open the Template is set up a Playback Configuration.
1. Click on the “New” button. A new configuration will allow you to add other devices if needed.
2. Name the new configuration to suit your liking.

3. Activate Sibelius Player. Select the SE6 SoundSet 6.0a sound set from the “Sound Set”
drop down menu. Save the configuration.

Playback Devices
Configuration: [Have a great day! '] [ Save ] [ New... ] [ Rename... ] { Delete
Active Devices | Manual Sound Sets | P ounds | Effects| )
Available devices: 2 1 4@ devices:
" ,~
Device Type Device Type Sound Set
Microsoft GS Wavetable Synth ~ MIDI Sibelius Player Sibelius SE6 SoundSet 6.0a
GM-MODULE MIDI Activate >>
Kontakt 4 VST
Kontakt 4 VST << Deactivate
Kontakt 4 Kontakt
KontaktPlayer2 Kontakt
Test
[ Audio Engine Options... ] [ Close ]

In order to help you determine the preferred sound set to choose in the Sound Set drop-down
menu, we modified the name in regards to how it will show up in Sibelius. Be sure to choose
and assign the sound set labeled “SE6 SoundSet 6.0a”.



The one instance of Sibelius Player that is available can accommodate up to 128 instruments.
The default setting in Preferences for the number if instruments that can be loaded into it will
vary depending on how much RAM you have in your computer. If have only 2 GB of memory, it
will probably default to a limit of 64 instruments. And you’ll more than likely run out of available
memory before you run out of available slots, even when using Sibelius in 64-bit mode.

Using Multiple Libraries

When using more than one template from The Write Score, you will likely need to have your
configuration setup a little differently than described on the previous page. For an example of
what it would need to look like, please read the Post-Merge Checklist / Playback Configuration
section in Appendix D.

IMPORTANT: For the best results, each instrument that you use from this Template should have
their Device and Patch assignments in the Mixer both set to (Auto). The custom instrument
definitions and sound set will do all of the correct patch loading for you. (The Sibelius 7 Mixer
is what'’s pictured below, but the same applies to Sibelius 6 as well.) You shouldn’t ever need to
manually set them to (auto) as this is the state that Sibelius gives each staff by default.

(Auto)

— Sibelius Player [ NE=  (Auto)
o =A==

Device . » : §75-SE6 SoundSet 7.1a
: ' \ : VDL SoundSet 7.0a

RECAP:

1. You’re running Sibelius 6.2

2. You’re running the Sibelius Sounds Essentials library (Sibelius Player version)
3. You've installed the SE6 sound set (“SE6 SoundSet 6.0a”)

4. You've created a playback configuration that will use this new sound set.

With the above steps completed, it's time to open up the Template and get working!



Adding Instruments to the Score

After you’'ve opened the .sib file named “SE6_Template_6.0a”, navigate to Create > Instruments
(hover); the dialog box that appears will look similar to this:

Instruments
Add Instrument
Choose from: Instrument: Staves in score:
- SE6 Template 6.0a 808 Clean Kit [ Add to Score Default
All Instruments 808 Drive Kit =
Band Instruments 909 Clean Kit
Common Instruments 909 Drive Kit Delete from Score
Jazz Instruments Brush Kit
Orchestral Instruments Club Kit
Orff Instruments Fusion Kit
Rock and Pop Instruments General MIDI Kit
World Instruments Goa Kit Move
Up
Family:
Strings Down
Winds —
Brass
Guitars Extra staff
Keyboards
Voice Mies
Pitched Perc =
Drumline
Aux Perc Below
Synth
Small staff
[ cancel | [ ok |

The Family field has all of the SE6 instruments grouped into types, and are otherwise arranged
to maximize the use of field sizes for better viewing. Find the instrument(s) you would like to add
to the score, then do so.

After you have filled up the Staves in score field, you can order them however you wish by using
the Up/Down buttons. Click OK when you are done playing around in this dialog.



The Maps

IMPORTANT: This section refers to the file SE6_Maps_6.0a.pdf.

Overview

Each pitched instrument listed in the Maps file will have the following (if applicable):

« Keymap - Shows the trigger range of the patch file; also used for note input.

+ Sounds Chart - Shows what sounds are available and what Dictionary ltems access them.
Each unpitched instrument listed in the Maps file will have the following (if applicable):

» Input Map - These are very similar to the keymaps except that the layout has been modified
for the sake of user friendly note input.

* Mapping Diagram - Shows how the instrument is mapped.
 Input Variables - Gives the user more flexibility when entering and working with notes.

Pitched Instruments

Pitched instruments will be a more straightforward than the unpitched instruments and not
require as much explanation as to what we had to do to set them up in the Template.

Controller Changes & Keyswitches

The controller changes and keyswitches that are used in this Sounds  Dict. Item
Template will be processed by the SE6 sound set and Dictionary. Default*  nat. / reset
All you'll need to do is add the appropriate Dictionary ltem to Legato (slur)

the staff and Sibelius will trigger the correct sound for you. The Mute mute
Sounds chart to the right is an example of what you'll find in the Legato Niute_(slun) * mute
Maps file.

Sounds Above the Range

A few of the Guitar instruments have additional sounds above their normal playing ranges. We
haven’t done anything special with these in the setup of the instruments, but we just wanted you
to know they were there in case you didn’t. If you happen to find a useful way to use these in
your writing, please let us and others know what you have done by posting on the TWS Forum.
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Unpitched Instruments

If you use an unpitched instrument that is not defined in the Template, you may have some
unique challenges in getting Sibelius to correctly interpret your intent. By using the percussion
mappings setup in the SE6 Template, you can be certain that not only will the correct sounds be
played back during playback, but you will also know what it will look like before you even enter
any notes into the score. These assignments can be found in the Mapping Diagrams found in
the Maps PDF file.

NOTE: A sample Input Map and Mapping Diagram can be found at the bottom of page 16.

When entering notes into unpitched instrument staves with a MIDI keyboard via step-time entry,
Sibelius will place the correct notehead on the correct staff line/space for you, simply based
on the pitches you’re entering, which is why using a MIDI keyboard can save you tons of time!
Additionally, it may be good to know that using the built-in keyboard in Sibelius will get you the
same input results.

Below are a few of the important things to be aware of regarding the unpitched instruments
we’ve defined in this template.

Articulations

When you get into the mapping diagrams, you will see that only a few of the notes have
articulations that are assigned to them. These instrument mappings have been optimized to
allow you more flexibility as to whether or not you choose to use articulations in your scores. The
vast majority of notes will not require an articulation to be applied for proper playback to occur.

NOTE: In any given instrument, each notehead and articulation combination must
be unique on a per line/space basis.

If there are duplicates in the mapping, then the staff will more than likely not play back the way
you want. This is a critical aspect of SoundWorld, but if everything is set up properly, it is very
user-friendly indeed.

(Continued on next page.)
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The articulations that may be used in this Template include the following and line up with the
picture below from left to right/top to bottom:

Keypad 1: Accent, Staccato, Tenuto.

Keypad 3: Z on stem, 4 Tremolo, 8 Tremolo.

Keypad 4: Custom Articulation 1*, Wedge, Marcato, Staccatissimo, Plus/Closed, Upbow,
Downbow, Harmonic/Open.

Keypad [ | Keypad [ | Keypad [ | Keypad (& | Keypad [ | Keypad &
El=rAn/ /b | omraan/b | o=wBAL b | o=@/ | o=wrAFb | o=r A/l
L Lol el SR Ro ol 1 1 L s s ]|
BB R b G S LR AN
el alald 2O
A1 ol ... | || ubgtaf()
27 N - 1 x|

faf2(3(afanl | [2]2|3|4 AN | [2{2(3]a]an

laf2(3{afan | fa|23 4l | [2]|2]3]|a]an

* The Inverted Mordent symbol is assigned to the first position available of the Custom Articulation
spaces (4th keypad, in blue, above the Marcato). This has been assigned this way to help
facilitate a few of the sounds that are in the template made for the Virtual Drumline sample
library. As this portion of the setup is not used in the SE6 Template, feel free to use it as is, or
make the adjustments to better suit your needs. VDL users will need to make sure to not
change this setting.

IMPORTANT: In the unpitched instruments’ diagrams, if a note has an articulation
assigned to it, this articulation must also appear in your score in order for the correct SE6
sound to be triggered.

NOTE: If you want to change an articulation in a percussion mapping to suit your personal
preference, make sure that you experiment in a file that you use just for that. Then, if
everything goes as planned, you can do it for real in the file you intend to use the change
in.
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Tremolos

Yellow highlights: In the mapping diagrams, the yellow highlighted notes’ playback will be
dependent on the notehead that is assigned to it. So for example, if you've entered notehead
0, but the roll you want to playback is assigned to notehead 20, it won’t playback properly until
you’ve changed the notehead to 20. At that point you may choose to use any of the tremolo
(slash) notation, Z on stem, or none at all. *

The tremolos that can be used with any of the yellow highlighted notes include these (also
shown in the following keypad picture).

* 4 tremolos (2 slashes) + 8 tremolos (3 slashes) * Buzz roll (Z on stem)
Keypad ] | Keypad (& | Keypad [ | Keypad [ | Keypad [ | Keypad &
B=rA /b | omAA~/Rb | o=RA/Lh | o=R@s b | o=rmARb [ o=r~ /B
g 1 2 3 M S R ] [

Big] b el Jlwn|T (@] & =E|=|'|"_‘_ Lialr J"\'.o.'..f\./.% b | <4

IR NNNDAGEE0 RnnD R S e
O .. I5.. Alalm 7 | »

ool |l LELE L

37 . - = m Iml x o

baf2 (3 |alan | frf{2(3|alan | f[a{2(3{afan | (2{2(3{a{anl | [2{2

Orange highlights: A few of the instruments have orange 102304 A0
highlighted notes in their diagrams. These noteheads REQUIRE
either a 2 slash tremolo or a 3 slash tremolo for their roll sounds
(except on its release note). This part of the setup allows the roll sounds to “release” properly
without re-triggered at the end of the roll.

* There are exceptions to the yellow highlight rule. In a few pages we’ll discuss Input Variables.

Controller Changes & Keyswitches

The controller changes and keyswitches that are used in this Template will be processed by the
sound set and Dictionary. All you’ll need to do is add the appropriate Dictionary Item to the staff
or note and Sibelius will trigger the correct sound for you. Additionally, just changing a notehead
to a different number, or moving the note up or down on the staff could also change the sound
(view each instrument’s diagram for what is available). The main thing here is that Sibelius does
the vast majority of the work for you with just a few simple commands.
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Naming Convention

Every Sibelius Player patch in the Essentials library has a corresponding instrument defined
within the SE6 Template. If you open the Instruments window (shortcut: 1), you'll see that there
is an ensemble called “- SE6 Template 6.0a”. Within that ensemble are various “Families”
containing different categories of SE6 instruments. This should all be pretty self-explanatory.

Once you've assigned instruments to your score, or if you do instrument changes mid-staff,
you can view exactly which instrument is loaded if you have View > Hidden Objects (hover)
checked. By viewing hidden objects, you'll see that the instruments (or instrument changes)
in your score will display the hidden text which will in turn give you an indication as to which
Ensemble it’'s a part of.

The grayed out (hidden) text will not appear in the printed score. However, you may wish to
deactivate Hidden Objects prior to printing, or put a line break into your staff names so the
hidden portion of the instrument name doesn’t affect the spacing between the staff name and
the left bar line.

More Instrument Definitions

If you use multiple parts for a given instrument (e.g. Violins), we have created several duplicates
for you already. Each instrument has its own unique sound ID which will tell Sibelius to load the
respective patch into its own channel/slot. This will help alleviate any mixed signals or triggers
that Sibelius could potentially send to Sibelius Player during playback.

Here’s the list of duplicate/new instruments that were made:

* Violins 1,2, 3,4  Trumpets 1,2, 3,4
* Violas 1,2, 3 * Mellophones 1, 2
* Cellos1,2,3 * Trombones 1, 2

Double Basses 1, 2
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Inputting Notes

This section primarily deals with unpitched instruments.

With a keyboard

Most people find the easiest way to input notes into the score is to use a MIDI keyboard that
is attached to their computer. When you type in a pitch on your MIDI keyboard, Sibelius will
correctly and automatically input the notehead which corresponds to that sound and it will be
placed in the correct location on the staff.

Once you have entered notes that have articulations assigned to them, you will then have to add
the corresponding articulations so the program knows which sounds to trigger in Sibelius Player.
You can also add them as they’re being entered, just depends on which way you like to work.

The keymaps and Input Maps specifically designed to be used with this Template are in the
included file labeled SE6_Maps_6.0a.pdf. These maps not only show you where to access
the sounds in relation to a MIDI keyboard, but they also contain the Template Dictionary Items,
notehead variations, and articulations (if necessary) that you will need to know when using a
MIDI keyboard for note input. Read the instructions in that file for more information.

Without a keyboard

If you choose to not use a MIDI keyboard, you can enter notes manually and edit the noteheads
and/or staff placements afterwards so they reflect the assignments defined in the mapping
diagrams. Or better yet, the octave number listed on every C key of each Input Map can be used
as a reference of where to click Sibelius’ built-in keyboard to get the same input results as if you
were using a plugged in MIDI keyboard.

Entering Modwheel Changes & Keyswitches

You won’t have to manually enter controller changes or keyswitches. The Dictionary Items, sound
set and applicable percussion mappings will handle all these switches for you.

Again, the sound set is an important part of how all this is designed to function. Make sure the
correct one is assigned in your Playback Configuration.

Input Variables

When you come across a diagram that has bracketed notes (as seen in the example below),
these indicate sounds with Input Variables. An input variable allows you the option to choose
different input methods to achieve the same result for certain sounds. When you see Input
Variables within the mapping diagrams, the first note displayed will not have an articulation
(could be yellow highlighted though). Any subsequent notes will have articulations.
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Depending on how you prefer to work, this feature gives you added flexibility when inputting
music and may not require as much need to alter notehead numbers when working with or
without a MIDI keyboard.

@ The example to the left is from the Cymbals instrument. Say you

® enter notehead #1 into your cymbal part to get the “crash” sound, but

@%(\ C\q&‘\ you then change your mind and decide to go with a “crash choke.”
C—— Rather than changing the note to notehead #40 (which you can still

T %* %* do if you'd like) simply add a staccato onto your previously entered
notehead #1. Voila! Insta-choke!

1 40 1

Not all of the Input Variables function quite the same way, but as you
work with the mapping diagrams, you'll start to get a feel for the designed functionality. These
variables are reflected in the input maps as well.

IMPORTANT NOTE: Keep in mind, when using a MIDI keyboard, the resulting notehead
entered will be the first one you see listed within the bracketed Input Variables. Subsequent
noteheads within the bracket illustrate how applying an articulation can alter the sound on
a note using a more commonly or already used notehead.

Here’s an Input Map and Mapping Diagram example taken from the Maps file. Hover your cursor
over the key with the yellow halo to reveal its Input Variable.

Fusion Kit

Show Hide

3 4
Low High .
Lopse Claps Splash Crash Ride Ride Tight Loose Pedal
Kick
Cymbals Hi-Hat
Tight Tight Hit Hit Rim Side
Kick Kick 1 2 Knock Stick 6 5 4 3 2 1
1 2
Snare Drum Toms
-
S Y a2
O <L e X
O > X AR AP
‘('\\'\ \(Q’ & O N (Q*' be,% \&’\\' Y G (_S\'b(}(z? & O\$<1~ \'b.QL)
KOO (RIS & N ¥ 7S C
L1 L o X X % E e ‘
T T T o f f I I f < I
I I I I T I I I I I
o @ © | I I I I I I U I I o
o 1 | ! 3 1 <
0 31 32 0 31 M 1 0 0 0 0 0 0 40 41 40 1 1 1 1 1 6
Kick Snare Toms HiHat Cymbals
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Playback Dictionary

NOTE: The dictionary items used by this template are listed on a per instrument basis. Please
refer to each instrument’s Map in the file SE6_Maps_6.0a.pdf.

For a long time now, Sibelius has used a powerful feature called Dictionary to control certain
things playback-wise. We can do a lot with it to control certain aspects of the Template without
needing to resort to cryptic MIDI messages. You can always view what’s available in the Playback
Dictionary by going to Play > Dictionary. We've already setup the playback functions for SE6 in
the Template, so as long as you’re using the dictionary terms outlined here, everything should
work as expected.

A valuable feature of the Sibelius dictionary is that it can perform certain tasks based on the
articulations used in your parts. For example, you may write a part for Timpani that is supposed
to roll (tremolo). So you put three slashes on the note so your timpanist knows it’s a rolled part.
Since SE6 contains actual sampled rolls, Sibelius will see these slashes, reference the dictionary
and the sound set, and realize this means it needs to playback SE6’s sampled rolls. It will also
ensure that it doesn’t try to “fake” the roll by performing a series of MIDI attacks since the sound
set has told Sibelius that this is an actual roll sample. This is a hugely time-saving feature of
Sibelius’ playback system. This sort of feature works for any SE6 patch that has sampled rolls
or tremolos.

Under the hood, what most of these definitions in the dictionary are doing is performing “sound 1D
changes” to create a new outcome. So for example, when your Electric Guitar staff encounters
the word “delay” essentially Sibelius interprets that as +delay, which will alter the sound of that
instrument. Sound ID’s can get pretty complex and there can be many variables at play, but the
way the sound set has been designed, you shouldn’t have to deal with them directly.

If you were to study the many sound IDs assigned in the dictionary, you'll see that [reset] is
a sound ID change used frequently. This resets any of the instrument’s altered mod-wheel/
keyswitch settings back to its default state, with no extra sound IDs affecting it. In any instrument,
you can always return to its default state by typing nat. into your score. nat. will activate the
[reset] sound ID message, and in many cases will look at home in your score.

You may find certain dictionary terms to be items you don’t necessarily want to print in your
score. Simply hide the text by selecting it then going to Edit > Hide or Show (hover). Alternately,
you could use a tilde (~) and as always, Sibelius will hide anything you type after it.
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Customizing Instruments

For Advanced Users

With the bulk of the busy work of the unpitched instrument mappings created already, tweaking
them to your own customizations may not be very daunting at all. As stated earlier, proper
playback is contingent on there being only ONE notehead/articulation combination per line or
space on the staff in each instrument mapping. You don’t have to have an articulation assigned,
but whatever you have has to be unique to that line/space.

Once you've learned the system, you'll find it's not difficult to make a copy of one instrument,

name it to your own convention, and then alter away.

Staff Type

Percussion ’ General [ Notes and Rests

& [ [ = = X X %]
0 3 20 51 29 40 38
< | 0 -
New ] [ Delete
Edit Note
Notehead: 5 @ ) v Position on staff:
Articulation: {(none) v
Best sound: | Drum 4 Sustained Buzz
[ Choose Sound... ]
Input using pitch [ vz~
Cancel ] [ 0K
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Moving Notes Up / Down on the Staff

The main area to pay attention to is the Input Using Pitch field which will change if you move
notes up or down on the staff in the Percussion tab of the Staff Type designer. Keep a mental
note of what the pitch is before you move it so you can change it back to what it should be after
you have moved the note up or down on the staff.

NOTE: As stated earlier, it might be a good idea to make whatever modifications you want
in a “test” file first. Then, when the results you want are achieved, make those exact same
changes in the file you will be using them in.

Noteheads List

If you were to create a new file using Sibelius, you would see that there are only 31 noteheads
available to you (numbers 0 thru 30). These are the default/stock noteheads that Sibelius
provides its users “out of the box”.

In this Template, the original 31 noteheads have not been modified in any way. However, in order
to be able to map the larger instruments we had to make several “twin” noteheads to be used
along with the originals.

You may have already noticed in the diagrams that certain noteheads were used over and over
again - and usually for similar kinds of sounds. This was not done just for the persons who may
be using this Template in their music writing, but also for the musician and or student who will be
reading and playing the music that is written.

And yet, we know there will still be users who will want to change things to suit their personal
preferences. With this Template - and more so the features in Sibelius - it will be much easier to
do so compared to previous versions.

(Continued on next page.)
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Crossover Noteheads

Notehead numbers 49 and 50 have been
reserved for crossover noteheads (used in
some of the drumline instruments). If in fact
you do want to change them from what we
have listed in the mapping diagrams, here is
how you can do it.

Navigate to House Style > Edit Noteheads
(hover). Scroll down to noteheads 49 and 50,
select the one you want to edit, click the Edit
button.

Notehead

Name:

Plays Transposes
Accidental Leger lines Stem
Notehead Symbols
Quarter note Half note Whole note Double whole note
S S © fot—
Change Symbol...

Stem Up: Stem Down:

Shorten stem by 016  spaces Shorten stem by 016  spaces

Move notehead 0.25  spacesright Move notehead 0 spaces left

Move notehead 0 spaces up Move notehead 0 spaces down

[ OK ] [ Cancel

Depending on which symbol you choose, you
may or may not have to change the “Move
notehead __ spaces right” value so that your
newly chosen notehead lines up with the
stem correctly. A little bit of trial-and-error will
get you to your destination.
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More than likely you will only need to edit
the quarter and half notes. Once you have
selected one of them click on the Change
Symbol button.

Symbol
Nmeheads|'|0|0‘||0|||=|0 x|®|x|e e’o‘/|ﬂ|v’v‘
L[ l=lef=l=]e [ NS A - [ ]
L REEERERT &
e S5 [ [ 195 [ [0 == Lo e oo e
=[PP
B EnERENANANEN=D
~[¢BIB[>n[0[5]2[4]¢]¢14]¢IBIBIB] -




In Closing

Congratulations! You are now at the end of this Readme and as such you are on your way to
becoming a true Sibelius/SE6 guru!

We’re always looking for feedback. If you happen upon anything that doesn’t work the way we’ve
described here, have template feature suggestions/requests, or just want to say “This is the best
writing tool ever!”, please be sure to let us know through our Forum or Contact page.

TWS Forum: forum.thewritescore.com

TWS Contact page: www.thewritescore.com/info/contact
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Appendix A

|ldentifying Template Versions

In all of the Sibelius Templates distributed by The Write Score, we've created a separate
Ensemble for each library-specific set of instruments and they’ve been named in accordance to
whichever version of Sibelius the template specifically applies to.

To check if you started a score that contains
the SE6 Template, simply go to Create >
Instruments (hover) and look at the “Choose
from:” (Ensemble) drop down list. You will
see one of the images to the right.

IMPORTANT: In your playback configuration,
the SoundSet version used needs to match

Choose from:

Choose from:

All Instruments

Band Instruments
Common Instruments
Jazz Instruments
Orchestral Instruments
Orff Instruments

Rock and Pop Instruments
World Instruments

All Instruments

Band Instruments
Common Instruments
Jazz Instruments
Orchestral Instruments
Orff Instruments

Rock and Pop Instruments
World Instruments

the Template version for that specific file
you’re working in.

SE6 Template 6.0 SE6 Template 6.0a

Updating Older Scores

Scores you’ve written in prior to having the SE6 Template can be “updated” by following the
steps below:

» For pitched instruments: Copying notes from the original score and pasting them into the
SEG6 score should be all you need to do for this.

* For unpitched instruments: You will need to manually re-enter everything into the SE6
score due to the differences in the instrument definitions’ notehead assignments.

« Some minor tweaking may be necessary to match the formatting elements of the original
score.

NOTE: The older the file is that you want to merge with this Template, the greater the odds
that there will be differences in noteheads lists. When Sibelius looks at each file to see what it
needs to do for the merge and if it sees that there are discrepancies between them, duplicate
noteheads will be created to compensate. Once this happens, there could be “corrupted”
notehead assignments in percussion instrument mappings. This is the primary reason why we
recommend the above process instead of exporting/importing House Styles.

Now, with that said, feel free to follow the instructions given in Appendix D to import this Template’s
House Style into your existing score. It won'’t hurt to experiment. And feel free to contact the TWS
template developer via our Support Forum with any questions concerning this not-well-known
“bug”.
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Appendix B

TriggerTest

Do you have your Sibelius/SE6 work environment setup properly?

NOTE: Sibelius Player does not have an interface that allows the user to do a true
TriggerTest (the ability to watch specific keys being triggered during playback). However,
we have still provided these files so you can do what we are calling a PlayTest.

There is a folder in the Template package you downloaded labeled “PlayTest”. Contained within
this folder is a set of sib files that has every template defined instrument and all the sounds (with
switch variations) on the staves with which you can use to perform a PlayTest.

Not only will you see written examples from this Template, but as you play each staff one at
a time, carefully listen so as to get an overview of ALL of the sounds that are available in the
SE6 sample library. There may very well be several sounds contained in this library that you
previously didn’t know about.

Pitched

Each pitched instrument will start out with its range followed by any applicable sound variations
via playing technique examples (i.e. staccato, tenuto, and so on).

Unpitched

Each unpitched instrument will have all of its diagram elements. First just the sounds in the
sequence of the Input Map (left to right on the keyboard), then the Input Variables after.

PLEASE BE ADVISED: These PlayTest files were created during the development process
and may not be complete. Use of these files for your writing projects is NOT recommended.
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Appendix C

Export Manuscript Paper

With the SE6 Template open, go to File > Save As and rename the file by adding a dash and a
space to the beginning of the name; should read “- SE6_Template_6.0a”. Adding the dash will
increase the odds that it shows up at the top of the Manuscript Paper list so you don’t have to
hunt and scroll to find it. (You can remove the underscores if you'd like.)

Next, navigate to File > Export > Manuscript Paper (hover). Sibelius will ask if you're sure you
want to do this. Click Yes. That'’s it, you've just created a Manuscript Paper based off of the SE6
Template.

Now, any time you want to start a new score, all you have to do is go to File > New (hover)
(shortcut: ctrl+n / cmd+n) to bring up the New Score dialog box, select the “- SE6_Template 6.0a”
manuscript paper from the list (optional: by clicking Change Instruments you can insert them into
the score from this dialog), and proceed accordingly.

New Score

Manuscript Paper

A
Bass staff

Big band

Blank

Brass band

Brass choir

Brass quartet

Brass quintet

Brass trio

Choir barbershop

Choir reduction

Choir reduction + organ
Choir SATB

Choir SATB + organ
Choir SATB + piano
Choir SSA

Choir SSA + piano
Choir TTBB

Choir TTBB + piano
Concert band

m

-

[ Change Instruments... ]

Page size: @ Portrait

[ Letter v ] ") Landscape

Previous Next > ] [ Finish

24



Appendix D

Merging Templates

If you have purchased this template separate from other TWS merge-compatible templates,
here is the quick and dirty on how to merge them into one file. In our example, we're going to

merge SE6 Template 6.0a and VDL Template 7.0a together.

RECOMMENDED: Always make backups of each file before starting this process.

Let’s start by looking at what each file looks like before the merge. Open them both and in each
one go to Create > Instruments (shortcut: I). Here is what we see in their Choose from lists:

Choose from:

Choose from:

- SE6 Template 6.0a

All Instruments

Band Instruments
Common Instruments
Jazz Instruments
Orchestral Instruments
Orff Instruments

Rock and Pop Instruments
World Instruments

SE6_Template_6.0a.sib

All Instruments

Band Instruments
Common Instruments
Jazz Instruments
Orchestral Instruments
Orff Instruments

Rock and Pop Instruments
World Instruments

VDL_Template_7.0a.sib

Next, from the SE6 Template we're going to export
its House Style. Navigate to House Style > Export
House Style (hover); the dialog to the right will appear.
Name the House Style however you wish, click OK.

Export House Style

Choose a name for your house style:

We won’t need the SEG6 file anymore so go ahead and SE6 Instruments

close it if you'd like.

Now go to the VDL Template 7.0 file. Navigate to

[ Cancel ] [ OK ]
House Style > Import House Style (hover). You'll be
presented with something like the image below.
— At this point you have thousands of choices, but thankfully we’re only

going to be dealing with two.

Choice 1 is to import the Playback dictionary and Instrument definitions
just like the image above shows. These two options MUST me check
to bring in the relevant merge items. For most people this will be the
likely choice.

(o] o)

(Hover o viewfarger) Choice 2 is to bring in any or all of the unchecked options in addition

to Choice 1. This may be necessary if there are certain settings - that
apply to the unchecked options only - that you have modified from their defaults and want to
keep.

After you have made the appropriate selections, click OK.
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OK? OK.

Now let's go back to Create > Instruments (shortcut: 1) Choose from:
and see if this whole merge process worked. - SE6 Template 6.0a
And there they are, our two templates successfully merged All Instruments
into one file Band Instruments

' Common Instruments

. o Jazz Instruments
This may be a good time to rename this file. How about Or$estral Instruments
: ’ : Orff Instruments

SE6-VDL_Bundle? And wh!le you're at it, go ahead Rock and Pop Instruments
and create a new Manuscript Paper by following the World Instruments

instructions given in Appendix C.

Can | use this same method to update my existing scores?

If you'd like to make use of this Template’s custom instrument definitions in your existing scores,
by all means, apply the previous instructions to them. If you missed our comments on the known
potential merging issues we mentioned earlier in this document, please go back up and read
them by clicking here.

Post-Merge Checklist

Playback Configuration

Since you’re now using instruments from at least 2 different libraries in your score, you’ll need to
have your Playback Configuration setup correctly. Let's use the following example to illustrate.

Say you're using the TWS templates that

Active devices: are built for these four libraries: Sibelius 7
e Type Sound Set Sounds, Virtual Drumline, Garritan Personal
ARIA Player Aria GPO SoundSet 7.0 Orchestra and Garritan Concert and Marching
ARIA Player (2)  Aria COME SoundSet 7.0 Band. You would need to have your Playback

Configuration’s Active Devices list setup

Kontakt 5 Kontakt VDL SoundSet 7.0a imilar to the i the left
Kontakt 5 (2) Kontakt VDL SoundSet 7.0a simiiar to the image on the [eft.
Sibelius Player  Sibelius S7S SoundSet 7.1a If you happen to have more than 16 total

instruments, including Instrument Changes,
that point to one specific library, you’ll need to
have more than one instance activated to handle the number of channels/slots required to load
them all (except for SE6 with Sibelius Player). In this example, we’re heavy on percussion and
need to have 2 instances of Kontakt Player to account for the 20+ VDL instruments in the score.

SET YOUR MIND AT EASE: Don’t be concerned about which instruments get loaded
into which instance of whichever device. Since we’re using TWS’s Sibelius 7 family of
templates, the custom instrument definitions and sound sets from each one will take care
of the correct patch loading for you.
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Noteheads Count

We recommend you check to see that you still only have 64 noteheads after the merge (numbers
0 through 63). Navigate to Notations > Noteheads > Edit Noteheads (shift + Q) and scroll to
the bottom of the list. If the last notehead is labeled 64 or higher, there has been at least one
duplicate created during the merge process. This may not actually effect any of the instruments
you may use in your score, but using the file in this condition is not recommended.

If All Else Fails

If you’re having trouble with the above process, or just aren’t comfortable with attempting to
merge the files on your own, please use the TWS Contact page to submit a request to get a
download code for a .sib file that already has the templates in it you need. Please be sure to
include all applicable order numbers for faster request processing.
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